Написать программу вычисления суммы всех 3-х значных чисел, у которых сумма цифр кратно...

0 голосов
62 просмотров

Написать программу вычисления суммы всех 3-х значных чисел, у которых сумма цифр кратно числу а.Нахождения суммы цифр 3х значного числа написать подпрограмму. ( С ФУНКЦИЕЙ)
i = от 100 до 999
i=326
x = i div 100
y=i div 10 mod 10
z= i mod 10
S= x+y+z
2)Определить значение переменной после выполнения фрагмента алгоритма:
S:=24;
m:=3456;
while s>10 do begin
m:=m mod 10;
S:=s-m
end;
S:=S+m;
write(m);
МНЕ НУЖНО ИМЕННО РЕШЕНИЕ, А НЕ ТУПО ОТВЕТ!!!!!


Информатика (106 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Function T1(b:integer):integer;
begin
T1:=b mod 10 +(b div 10)mod 10+((b div 10)div 10)mod 10;
end;
Var
i,a,S:integer;
begin
S:=0;
For i:=100 to 999 do
  if T1(i) mod 3 =0
  then S:=S+T1(i);
writeln(S);
end.

(633 баллов)
0

S:=24;
m:=3456;
while s>10 do begin
m:=m mod 10;
S:=s-m
end;
S:=S+m;
write(m);

0

При первом запуске цикла получаем m=6 S=18

0

Далее начальное m=6, затем оно становится равно 0, т.е. S никогда не станет меньше 10

0

Но m остается равным 6

0

Ответ:6