Написать программу которая будет вводить ** экран максимальный элемент любого...

0 голосов
48 просмотров

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива


Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Если паскаль, то - 

const n:=100; //в массиве пусть будет 100 элементов
var tarray:array[1..n] of integer;
max:integer;
i:=byte;
begin
{тут заполнение массива}
max:=tarray[1]; //думаем что максимум - это первый элемент
for i:=1 to n do 
 if max > tarray[i]
  then max:=tarray[i];//если встречаем элемент больше максимального - то он -новый максимальный 
write('Максимальный элемент - ', max);
end.

(96 баллов)