Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в...

0 голосов
512 просмотров

Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b .

Входные данные
Входная строка содержит два натуральных числа, a и b . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести в одной строке через пробел все простые числа на отрезке [ a , b ] . Если таких чисел нет, программа должна вывести 0.

Примеры
входные данные
20 30
выходные данные
23 29
входные данные
24 28
выходные данные
0
На паскале, пожалуйста, очень нужно.


Информатика (34 баллов) | 512 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var A,B,C,D,k:integer;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
k:=0;
For B:= A to B do
    Begin
    D:=0;
    For C:= 2 to B do
        if B mod C = 0 then D:=D+1;
    if D=1 then k:=k+1
    End;
WriteLn(k);
End.

(34.0k баллов)