Написать программу в паскале для возведения в квадрат если число меньше 3, и деление...

0 голосов
56 просмотров

Написать программу в паскале для возведения в квадрат если число меньше 3, и деление данного числа на 2 если число больше 5


Информатика (56 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

Program zadacha;
var a,s:real;
begin
writeln('Введи число: ');
readln(a);
if a<3 then s:=a*a;<br>if a>5 then s:=a/2;
writeln(s:2:1);
end.

0

writeln(s:2:1); там 2 делить на 1?

0

Нет. Это дробная позиция, чтобы красиво читалось :) Можешь провести эксперимент. Убери ":2:1". Будет некрасиво читаться.

0

в этой строчке кавычки не ставятся?

0

нет конечно.