Напишите программу удаляющая из текста все буквы совпадающие с его последней буквой
последнюю букву тоже нужно удалять?
незнаю, если честно
АВС
да
На паскале?
а то мне , кровь из носа, надо
решишь?
ну давай ипусть не удаляет
Uses crt; var s:string; n,i:integer; begin readln(s); n:=length(s); for i:=1 to n do if s[i]=s[n] then delete(s,i,1); writeln(s); end. Эта программа рассчитана на то, что удаляется и последний символ тоже
А у меня выход за границы массива, т.к. n не меняется, ну да ладно.
у меня все подошло)))
аа получилось))))
ага , сейчас проверю
Var s:string; i:integer; begin read(s); i:=1; while iif s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i) else i+=1; write(s) end.
обычный
А, у вас обычный или .net? Если обычный, то лучше другой вариант.
спасибо))))
оо, у тебя не удаляет, я незнаю какой точно переписывать
тоже спасибо)))
Ясно