Помогите с написанием программы!Нужно написать программу в Паскале. Найти сумму...

0 голосов
42 просмотров

Помогите с написанием программы!Нужно написать программу в Паскале. Найти сумму а1+2а2+3а3+..+8а8


Информатика (32 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

Program sum;
uses crt;
var
a,r:real;
i:integer;
begin
clrscr;
r:=0;
writeln('Vvedite chislo a: ');
read(a);

for i:=1 to 8 do r:=r+(i*a*i);
writeln('Otvet: ',r);
end.

(1.0k баллов)