Написать программу паскаль. Вычислите произведение P=1/2*2/3*3/4...10/11 (результат...

0 голосов
45 просмотров

Написать программу паскаль.
Вычислите произведение P=1/2*2/3*3/4...10/11 (результат записать с точностью до 8 знаков после запятой)


Информатика (20 баллов) | 45 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
   P:real;
   A:integer;
Begin
P:=1;
For A:= 1 to 10 do
    P:=P*A/(A+1);
Write('P = ',P:0:88);
End.

Результат работы программы:

P = 0.09090909

(34.0k баллов)
0 голосов
\displaystyle P=\prod_{i-1}^{10} \frac{i}{i+1}= \frac{1}{2}\times \frac{2}{3}\times \frac{3}{4}\times ... \times \frac{9}{10}\times \frac{10}{11}= \\ \frac{1\cdot2\cdot3\cdot...\cdot9\cdot10}{2\cdot3\cdot4\cdot...\cdot10\cdot11}= \frac{1}{11}

begin
  Writeln(1/11:0:8)
end.

Результат
0.09090909
(150k баллов)