ДРУЗЬЯ,ПОМОГИТЕ ПОЖАЛУЙСТА♥♥♥ отдаю все баллы, что есть)) 1) Напишите программу, которая...

0 голосов
31 просмотров

ДРУЗЬЯ,ПОМОГИТЕ ПОЖАЛУЙСТА♥♥♥ отдаю все баллы, что есть))

1) Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 3. Программа должна вывести одно число- минимальное число, кратное 3.

2) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, кол-во введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Значение выводить с точностью до десятых.

Решить на Паскале♥
Буду очень благодарна!♥♥♥


Информатика (190 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var A,Min,n:longint;
Begin
Write('Количество чисел: ');ReadLn(n);
Repeat
Read(A);
n:=n-1;
Until A mod 3 = 0;
Min:=A;
For n:= n downto 1 do
    Begin
    Read(A);
    if (A < Min)and(A mod 3 = 0) then Min:=A
    End;
WriteLn(Min)
End.



Var
   A,k:longint;
   S:real;
Begin
k:=-1;
S:=0;
Repeat
Read(A);
if A mod 8 = 0 then
   Begin
   S:=S+A;
   k:=k+1;
   End;
Until A = 0;
if k = 0 then WriteLn('NO')
else WriteLn('Sr = ',S/k:0:1)
End.

(34.0k баллов)
0

СПАСИБО ТЕБЕ ОГРОМНОЕ дай бог тебе здоровья

0

Как то странно работает программа для задачи 1. Находится первое число, кратное 3, затем ищется минимум среди чисел, стоящих до числа, кратного 3 ? А если чисел, кратных 3 несколько? Например, при таком вводе: Количество чисел: 6
-12 15 17 -17 11 19
-17

0

Программа просто нашла минимум - число - 17, это число не делится на 3.

0

Ой, нуу это плохо. А ты не знаешь, как решить?

0

"в последовательности натуральных чисел" Они все должны быть больше нуля

0

srzontmp, читайте внимательнее и задание, и программу

0

Но программа действительно написана с парой ошибок: "For n:= n-1 downto 1 do" - тут не надо вычитать единицу, "if A < Min then Min:=A", а тут добавить условие кратности трём