Написать программу через паскаль среднее арифметическое ста чисел случайным образом в...

0 голосов
62 просмотров

Написать программу через паскаль среднее арифметическое ста чисел случайным образом в массиве от 50 до 100


Информатика (95 баллов) | 62 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(100,50,100); a.Println;
  Writeln('m=',a.Average);
end.

Пример
79 81 50 65 72 67 78 88 89 61 54 71 56 90 84 93 62 57 52 59 58 53 98 83 63 61 57 68 85 98 68 93 50 88 60 96 51 97 71 90 89 62 93 78 55 59 97 72 72 90 64 74 57 87 72 75 84 68 51 60 60 60 52 92 94 62 70 69 79 88 91 65 86 62 70 96 61 69 77 54 65 86 96 96 84 94 85 64 65 85 62 84 96 60 80 79 59 51 85 94
m=73.82
(150k баллов)