Ребят, помогите!написать программу:Является ли сумма цифр заданного 7-значного числа,...

0 голосов
41 просмотров

Ребят, помогите!
написать программу:

Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах десятков тысяч, сотен и единиц (1 234 567) числом четным или кратным 7?


Информатика (167 баллов) | 41 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var
  s, x, n: integer;
begin
  writeln('Введите число: ');
  read(n);
  x := 1000000;
  repeat
    s := s + (n div x) mod 10;
    x := trunc(x / 10);
  until x < 1;
  writeln('Сумма = ', s);
  if s <> 0 then
  begin
    if s mod 2 = 0 then writeln('Сумма - число четное')
    else writeln('Сумма - число нечетное');
    if s mod 7 = 0 then writeln('Сумма - число кратное 7')
    else writeln('Сумма - число не кратное 7');
  end;
end.
(1.4k баллов)
0 голосов

PascalABC

var
i,k,b:integer;
a:array[1..7] of integer;
begin
for i:=1 to 7 do
read(a[i]);

b:=a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7];

if (b mod 2 = 0) or (b mod 7 = 0) then
writeln('Это число четное либо кратно 7')
else writeln('Это число не четное и не кратно 7);
end.

(1.2k баллов)