Напишите программу для решения следующей задачи.Ученики 4 класса вели дневники наблюдения...

0 голосов
606 просмотров

Напишите программу для решения следующей задачи.
Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда столбик термометра поднимался выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней поднималась выше нуля градусов.
Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Информатика (49 баллов) | 606 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,S,k,t:integer;
Begin
S:=0;
k:=0;
Read(n);
For n:= 1 to n do
    Begin
    Read(t);
    if t > 0 then
       Begin
       S:=S+t;
       k:=k+1;
       End;
    End;
WriteLn('k = ',k);
Write('Sr = ',S/k)
End.

(6.6k баллов)