составить программу для решения следующей задачи. из строки выбрать все цифры и...

0 голосов
34 просмотров
составить программу для решения следующей задачи. из строки выбрать все цифры и сформировать другую строку
S=sdfg745tg2345dfg74
M=7452234574


Информатика (12 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
var
i:integer;
s,m:string;
begin
readln(s);

for i:=1 to Length(s) do
  if s[i] in ['0'..'9'] then m:=m+s[i];

write(m);
end.
(558 баллов)