Написать программу ** Паскале: ** вход подаются целые числа до появления нуля. Вывести...

0 голосов
71 просмотров

Написать программу на Паскале:
На вход подаются целые числа до появления нуля. Вывести максимальное количес тво подряд идущих чисел, кратных 3.


Информатика (179 баллов) | 71 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   x, n, max: integer;
 
begin
  n := 0;
  max := 0;
   while true do
   begin
    read(x);
     if(x mod 3 = 0)and(x<>0) then n := n + 1
     else begin if(n > max) then max := n; n := 0; end;
     if(x = 0) then break;
  end;
  write(max);
end.

(3.7k баллов)