Напишите программу для Паскаля АБС (старая версия) Сумма от 1 до 5 Написать Сумма_до То...

0 голосов
42 просмотров

Напишите программу для Паскаля АБС (старая версия)
Сумма от 1 до 5 Написать Сумма_до
То есть вид программы Сумма_до


Информатика (1.5k баллов) | 42 просмотров
0

В Паскале есть три вида циклов: For, While и Repeat Until - с параметром, с предусловием, и с постусловием соответственно. "For" = "для", это ещё ясно, но здесь - не знаю, выбирайте из оставшихся=)

0

Repeat

0

Repeat Until

Дан 1 ответ
0 голосов
Правильный ответ

Var
   S,i:integer;
Begin
S:=0;
i:=1;
Repeat
S:=S+i;
i:=i+1
Until i > 5;
WriteLn('S = ',S);
End.

(6.6k баллов)