Составить программу в паскале по выводу знака зодиака

0 голосов
73 просмотров

Составить программу в паскале по выводу знака зодиака


Информатика (33 баллов) | 73 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

 Var
   d,m:byte;
Begin
Write('Введите день: ');ReadLn(d);
Write('Введите месяц: ');ReadLn(m);
Case m of
3:if d<21 then Write('Рыбы')<br>  else Write('Овен');
4:if d<21 then Write('Овен')<br>  else Write('Телец');
5:if d<22 then Write('Телец')<br>  else Write('Близнецы');
6:if d<22 then Write('Близнецы')<br>  else Write('Рак');
7:if d<23 then Write('Рак')<br>  else Write('Леа');
8:if d<24 then Write('Леа')<br>  else Write('Дева');
9:if d<24 then Write('Дева')<br>  else Write('Весы');
10:if d<24 then Write('Весы')<br>  else Write('Скорпион');
11:if d<23 then Write('Скорпион')<br>  else Write('Стрелец');
12:if d<22 then Write('Стрелец')<br>  else Write('Козерог');
1:if d<21 then Write('Козерог')<br>  else Write('Водолей');
2:if d<19 then Write('Водолей')<br>  else Write('Рыбы');
else Write('Нет такого месяца')
End;
End.

(34.0k баллов)