Напишите программу ** Паскале вывода значения true, если точка с заданными координатами...

0 голосов
46 просмотров

Напишите программу на Паскале вывода значения true, если точка с заданными координатами (х,у) лежит внутри заштрихованной области и false, если не лежит.


image

Информатика (15 баллов) | 46 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
   x,y:real;
Begin
Write('x = ');ReadLn(x);
Write('y = ');ReadLn(y);
WriteLn((x*x+y*y<=36)and(x>=2));
End.



Примеры работы программы:

x = 3
y = 4
True

x = 5
y = 5
False

(34.0k баллов)
0 голосов

Var
  x, y: real;

begin
  readln(x, y);
  if (x * x + y * y <= 36) and (x >= 2) then
    writeln('True')
  else
    writeln('False');
end.


(314k баллов)