7.Написать программу ** Паскале вычисления значения функции (х^2 при х>0 х-12 при х≤0)...

0 голосов
183 просмотров

7.Написать программу на Паскале вычисления значения функции
(х^2 при х>0
х-12 при х≤0)
8.Написать программу на Паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры.
9.Написать программу на Паскале вычисления значения выражения у=15х3+3х2-6
10.Написать программу на Паскале вычисления значения функции
(х^2+5х-4 при х>3
х при х≤3)


Информатика (38 баллов) | 183 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//7.Написать программу на Паскале вычисления значения функции(х^2 при х>0 х-12 при х≤0)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>0 then writeln('Ответ ', power(x,2))
else writeln('Ответ ', x-12);
end.

//8.Написать программу на Паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры.

var
a,b,c,d:integer;
begin
writeln('Введите a,b,c,d');
readln(a,b,c,d);
writeln('P= ', a+b+c+d);
end.

//9.Написать программу на Паскале вычисления значения выражения у=15х3+3х2-6

var
x:integer;
begin
writeln('Введите x');
readln(x);
writeln('Ответ ', 15*power(x,3)+3*power(x,2)-6)
end.

//10.Написать программу на Паскале вычисления значения функции(х^2+5х-4 при х>3х при х≤3)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>3 then writeln('Ответ ', power(x,2)+5*x-4)
else writeln('Ответ ', x);
end.

0

Я добавляла ещё подобные задания, если Вам не трудно, не могли бы Вы их тоже решить?

0

Да, все готово)