СРОЧНООО , ПОМОГИИИТЕ(((( Ниже записана программа. Получив ** вход число , эта программа...

0 голосов
54 просмотров

СРОЧНООО , ПОМОГИИИТЕ((((
Ниже записана программа. Получив на вход число , эта программа печатает два числа, L и M .Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
if x mod 2 = 0 then
M:= M + x mod 10;
x:= x div 10;
end;
writeln(L); write(M);
end


Информатика (20 баллов) | 54 просмотров
0

999

Дан 1 ответ
0 голосов

На каждой итерации цикла у числа x отбрасывается последняя цифра пока x не станет 0.
К переменной M прибавляется последняя цифра числа x если x-четное число.
Переменная L выводит количество цифр в числе x.
Если L должна быть равна 3 ,а  M - 0 , то число x должно быть трехзначным и не содержать четных цифр.
Максимальное такое число - 999.

(3.7k баллов)