Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено...

0 голосов
242 просмотров

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.


Информатика (23 баллов) | 242 просмотров
Дан 1 ответ
0 голосов

Program z1;
var a,i,sum,p:integer;
Begin
sum:=0;
p:=1;
repeat
begin
read(a);
sum:=sum+a;
p:=p*a;
until a=0
end;
writeln(sum,p);
End.

(208 баллов)