** языке Паскаль напишите программу, решающую следующую задачу: Программе ** вход...

0 голосов
24 просмотров

На языке Паскаль напишите программу, решающую следующую задачу:
Программе на вход подается последовательность символов, завершающаяся символом '.' (точка). Идущие подряд последовательности цифр пятеричной системы счисления рассматриваются как числа.
Например, последовательность sdf812973j223k содержит три пятеричных числа: 12, 3 и 223. Числа могут быть сколь угодно большими. Знаки '+' и '-' не рассматриваются как части числа.
Напечатайте сумму всех таких чисел, которые не превосходят 2^19-1. Можете предполагать, что сумма не превосходит 2^31-1. Если чисел, удовлетворяющих условиям, в последовательности нет, сумма полагается равной - 1.


Информатика (33 баллов) | 24 просмотров
0

Внимательно прочитайте 3-й абзац, пожалуйста.

0

Рассматривайте числа 12, 3 и 223 в десятеричной системе счисления

0

в четвертом абзаце произошла ошибка

0

извините за оплошность

0

там написано три пятеричных числа

Дан 1 ответ
0 голосов
Правильный ответ
1. Современное решение

// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

function From5to10(Self:sequence of string):sequence of integer;
    extensionmethod;
// Перевод последовательности заданных на строках пятиричных чисел
// в последовательность целых десятичных чисел
begin
  foreach var s in Self do begin
    var r:=0;
    var pa:=1;
    foreach var c in s.Reverse do begin
      r+=c.ToDigit*pa; pa*=5
    end;
    yield r
    end
end;

begin
  var s:=ReadlnString('Введите строку:').MatchValues('[0-4]+').From5To10;
  if s.Count=0 then Writeln('S=-1')
  else Writeln('S=',s.Sum)
end.

Пример
Введите строку: sdf812973j223k
S=73

2. Решение на TurboPascal ("Так писали наши отцы и деды в 1983 году, так и нас сейчас учат в школе")

uses Crt;

function From5to10(n:string):integer;
{ Перевод из пятиричного числа в строковом представлении
  в целое десятичное }
var
  i,pa,s:integer;
begin
  s:=0;
  pa:=1;
  for i:=Length(n) downto 1 do begin
    s:=s+pa*(Ord(n[i])-Ord('0'));
    pa:=pa*5
    end;
  From5to10:=s
end;

var
  s,w:string;
  i,k,r:integer;
begin
  ClrScr;
  Write('Введите строку: ');
  Readln(s);
  w:='';
  r:=0;
  k:=0;
  for i:=1 to Length(s) do begin
    if Pos(s[i],'01234')>0 then begin
      if w='' then k:=k+1;
      w:=w+s[i]
      end
    else
      if w<>'' then begin
        r:=r+From5to10(w);
        w:=''
        end
    end;
  if k=0 then Writeln('S=-1')
  else Writeln('S=',r);
  ReadKey
end.
(150k баллов)