Напишите программу ** языке Паскаль!!! ** экран вводится два пятизначных числа. Найти...

0 голосов
48 просмотров

Напишите программу на языке Паскаль!!! На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем числе.


Информатика (38 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b, n: integer;
  sr: real;
 
begin
  sr := 0;
  n := 0;
  read(a, b);
  if(a > b) then a := b;
  while a > 0 do
   begin
    if((a mod 10) mod 2 = 0) then begin
      sr := sr + a mod 10;
      n := n + 1;
    end;
    a := a div 10;
  end;
  write(sr / n);
end.

(3.7k баллов)
0

Попробуйте скачать последнюю версию PascalABC.NET.

0

Она у меня и стоит

0

Версия 3.2.0.1443?Если нет то обновите.

0

Что делать ? Он просто пишет Nan

0

У меня самая последняя версия

0

От какого числа сборка?

0

Я без понятия

0

Школьный компьютер

0

Спасибо Огромное

0

Все работает