Составить программу есть ли среди чисел x y z числа кратные 5. если такие числа имеются...

0 голосов
22 просмотров

Составить программу есть ли среди чисел x y z числа кратные 5. если такие числа имеются то увеличить их на 1


Информатика (16 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Не указано на каком языке программирования нужно, поэтому напишу уж на Паскале. Всё сделал так, чтобы было понятно, хоть и не так компактно.

Var    x, y, z:integer;
Begin    
Write('Введите числа X, Y и Z^: '); 
Readln(x, y, z); 
If x mod 5=0 then x:=x+1;
If y mod 5=0 then y:=y+1;
If z mod 5=0 then z:=z+1;
Writeln('Полученные в итоге числа(X, Y, Z):', x, ', ', y, ', ', z);
End.

(1.5k баллов)
0

Почему-то слетели строчки. Думаю, разберётесь, где переносить в другую строку. Если получится, то исправлю.

0

Спасибо! На паскале

0

Помогите еще с одной задачей пожалуйста

0

там с системой

0

Создайте новый вопрос и укажите там условие. Посмотрю, может смогу вспомнить Паскаль.

0

создала уже

0

заранее огромное спасибо