** вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6...

0 голосов
233 просмотров

На вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6 степени. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.


Информатика (753 баллов) | 233 просмотров
0

Паскаль? Бейсик? Си?

0

паскаль

Дан 1 ответ
0 голосов

Var n,m:longint;
Begin
Read(n,m);
Write((n mod m)*(m mod n)+1)
End.

(6.6k баллов)
0

да

0

вы написали программу , при которой выдается не рандомное число

0

Чем программа не соответствует условию?

0

А где в условии сказано, что нужно выдать рандомное?

0

в противном случае - любое другое число

0

Любое, но не единицу. Так и есть - в чём проблема?

0

Если делится - единицу, в противном случае - всё, что угодно, кроме единицы.

0

вы уверены ,что это правильное решение?

0

Любое, и случайное - разные вещи\\ Да, уверен.

0

Хорошо. Спасибо

0
Это неправильный ответ. Введите 5 и 2 и убедитесь. Не вводите людей в заблуждение.