Помогите! Нужно нарисовать блок схему и написать программу ** языке Турбопаскаль( ТП)...

0 голосов
37 просмотров

Помогите!
Нужно нарисовать блок схему и написать программу на языке Турбопаскаль( ТП)
Задача во вложении.
Пожалуйста опишите все подробно, я мало что понимаю тут.


image

Информатика (1.1k баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схема - в прилагаемом файле.
Программа:
program p3;
var a,b,s,k,i:integer; // описание переменных
begin
a:=500; b:=900;  // задание значений переменным a и b
s:=0; k:=0;   // задание начальных значений s и k
for i:=a to b do // цикл с параметром i, который меняется от a до b
 if (i mod 3=0)and(i mod 5=0) then // если остаток от деления i на 3=0 и
                                                       // остаток от деления на 5 =0, то 
  begin s:=s+i; k:=k+1; end; // добавляем найденное число к сумме (s) и 
                                            // увеличиваем на 1 количество найденных чисел
writeln('Искомое среднее арифметическое = ',s/k:5:1); // вывод на экран
readln;
end.

Результат:
Искомое среднее арифметическое = 705.0


image
(194k баллов)