Паскаль. Составить программу для решения следующей задачи: Даны числа a, b - целые (<>0)....

0 голосов
78 просмотров

Паскаль.
Составить программу для решения следующей задачи: Даны числа a, b - целые (<>0). Сократить дробь a/b.

Сначала найти НОД этих двух чисел. Затем знаменатель и числитель разделить на НОД.


Информатика (85 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p,q:integer;
  Write('Введите числитель и знаменатель: '); Read(p,q);
  var a:=abs(p);
  var b:=abs(q);
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  p:=p div a;
  q:=q div a;
  Writeln('Результат: ',p,'/',q)
end.

Пример
Введите числитель и знаменатель: 1440 16200
Результат: 4/45
(150k баллов)