Написать программу получить степени a:a,a^2,a^3,...., меньше чем b Делать в pascal abc,...

0 голосов
40 просмотров

Написать программу получить степени a:a,a^2,a^3,...., меньше чем b Делать в pascal abc, ребят помогите пожалуйста


Информатика (1.0k баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,p:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
p:=a;
while p begin
 write(p,' ');
 p:=p*a;
 end;
end.

Пример:
a = 2
b = 20
2 4 8 16
 

(194k баллов)