Составьте программу для решения следующей задачи : Дан массив из 20 элементов,...

0 голосов
32 просмотров

Составьте программу для решения следующей задачи : Дан массив из 20 элементов, заполненныей случайными числами . Найти минимальный элемент массива и его номера


Информатика (14 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

#include


using namespace std;

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    const int arr_len=20;
    int arr[arr_len];
    int i = 0;
    srand(8120);
    for (i = 0; i < arr_len; i++)
    {
        arr[i] = rand() % 100;
        cout << arr[i] << ' ';<br>    }
    cout << endl;<br>    int min = 100, min_index=arr[0];
    for (i = 0; i < arr_len; i++)
    {
        if (arr[i] < min)
        {
            min = arr[i];
            min_index = i;
        }
    }
    cout << "Минимальный элемент массива: " << min << endl;<br>    cout << "Его индекс: " << min_index << endl;<br>    system("pause");
}

(1.5k баллов)