Написать программу, ** языке Си, выводящую все чётные числа ** отрезке от A до B. В этой...

0 голосов
63 просмотров

Написать программу, на языке Си, выводящую все чётные числа на отрезке от A до B. В этой задаче нельзя использовать инструкцию if.


Информатика (177 баллов) | 63 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
int main (int argc, char *argv[])
{
    int A, B;
    printf("A = ");scanf("%d", &A);
    printf("B = ");scanf("%d", &B);
    A = A + A % 2;
    B = B - B % 2;
    for (A = A; A<=B; A = A+2)<br>        printf("%d ", A);
    getch();
}

(6.6k баллов)
0

Спасибо. А в какой программе ты пишешь программы на Си?

0

Dev-C++, но среду можно переключить и на Си

0

Спасибо огромное! Наконец то смогу писать программы на Си.