Написать программу в паскале: Дано 6 учеников, 3 предмета(физика , матем, русский) нужно...

0 голосов
50 просмотров

Написать программу в паскале: Дано 6 учеников, 3 предмета(физика , матем, русский) нужно чтобы по каждому предмету вычислить средний балл учащихся.
P.S на картинке половина уже есть


image

Информатика (17 баллов) | 50 просмотров
0

картинка не читабельна, и вообще код нужно выкладывать в тексте

0

кстати на картинке написан бред а не шаблон, все кроме русских фраз использовать не получится

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Введите построчно оценки шести учеников');
  Writeln('Порядок ввода оценок: физика, математика, русский');
  var d:=ReadMatrInteger(6,3);
  Writeln('Средние баллы по предметам');
  Writeln('Физика ',d.Col(0).Average:0:2,
    ', математика ',d.Col(1).Average:0:2,
    ', русский ',d.Col(2).Average:0:2)
end.

Пример
Введите построчно оценки шести учеников
Порядок ввода оценок: физика, математика, русский
4 5 4
3 4 4
5 4 5
3 3 4
5 5 5
4 4 3
Средние баллы по предметам
Физика 4.00, математика 4.17, русский 4.17
(150k баллов)
0 голосов

 В общем я написал прогу, но у неё куча недостатков
1)нет защиты от "дурака";
2)Имя вводится только числовое;
3)Возможно код можно упростить;


(804 баллов)
0

выводит средний балл то что она не оптимизированная это я написал

0

и написал где именно

0

А все понял спасибо за перевод) я просто не так перевёл фразу

0

ну это смотря где у меня в школе учительница всегда просила написать защиту от дурака

0

так что я всегда стараюсь её писать