Помогите написать программу ** паскале. Дан двумерный массив размером 5 * 5 элементы...

0 голосов
50 просмотров

Помогите написать программу на паскале.
Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте программу определения индексов минимального элемента этого массива. Полученный результат вывести на экран.


Информатика (115 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const  
n=5;
var  
a: array[1..n,1..n] of integer;  
i,j,im,jm: integer;

begin  
writeln('Массив:');  
for i:=1 to n do  
begin    
for j:=1 to n do    
begin      
read(a[i,j]);    
end;  
end;  
writeln;    

im:=1; jm:=1;  
for i:=1 to n do    
for j:=1 to n do      
if a[i,j]begin        
im:=i;        
jm:=j;      
end;  
writeln('Минимум = ',a[im,jm]);  
writeln('Строка: ',im,'  столбец: ',jm);  
readln;
end.

(314k баллов)