Помогите написать программу в Паскаль

0 голосов
33 просмотров

Помогите написать программу в Паскаль


image

Информатика (338 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1447 от 22.05.2017
// Внимание! Если программа не работает, обновите версию!

1. Современное решение (в "одну" строку)

begin
  Writeln('S=',ReadSeqIntegerWhile(m->m>0)
      .Where(m->(m mod 6=0) and (m mod 10=4)).Sum)
end.

Пример
34 18 174 14 24 236 114 0
S=312

2. А так учат в школе...

var
  m,s:integer;
begin
  s:=0;
  repeat
    Read(m);
    if (m mod 6=0) and (m mod 10=4) then s:=s+m;
  until m=0;
  Writeln('S=',s)
end.
(150k баллов)
0

Большое спасибо!