В паскале написать программу, которая вычисляет y по формуле y=√ab. В случае когда ab<0...

0 голосов
50 просмотров

В паскале написать программу, которая вычисляет y по формуле y=√ab. В случае когда ab<0 выводить на экран "решения нет". Заранее спасибо


Информатика (41 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

BEGIN
writeln('Введите А, В:');
readln(a, b);
if (a*b < 0)
then write('решения нет');
else write(sqrt(a*b));
END.

(1.4k баллов)
0

Неверное условие: должно быть >=

0

Прошу прощения, у Вас всё правильно. Я ошибся!