Y=5x^2+7x-30 составить программу вычисления

0 голосов
23 просмотров

Y=5x^2+7x-30 составить программу вычисления


Информатика (15 баллов) | 23 просмотров
0

язык программирования?

Дан 1 ответ
0 голосов
Правильный ответ

Преобразуем по схеме Горнера, избавляясь от вычисления степени х.
y = 5x²+7x-30 = -30+x(7+5x))

// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ReadReal('x=');
  Writeln('Y=',-30+x*(7+5*x))
end.

(150k баллов)