Написать программу, которая: 1. Дано вещественное число x, посчитать функцию,...

0 голосов
53 просмотров

Написать программу, которая:

1. Дано вещественное число x, посчитать функцию, возвращающую y=f(x), если
2. F(x) = 2*x, при x < 0;
3. F(x) = 0, при x = 0;
4. F(x) = x*x + 10, при x> 0;

Написать программу, которая:
1. Просит ввести год рождения человека;
2. Проверяет введенное значение (несколько параметров);
3. Вычисляет возраст человека;
4. Выводит на экран возраст и какую-либо характеристику (несколько параметров в зависимости от возраста в трех диапазонах).


Информатика (227 баллов) | 53 просмотров
0

Вроде понятно,но какие параметры нужно выводить во 2 программе.Укажите на каком языке программирования вам нужно решение.

0

С++ . ну как бы 20 лет молод 45 лет взрослый 75 лет старый просто cout возраст и все

0

Понял,спасибо за ответ.Ждите решение

0

У меня возникла небольшая заминка,решение готово.Но Ответить я из за чего-то не могу (Нет искомой таблички "Ответ и объяснения").

0

С момента добавление предыдущего ответа прошло 10 часов - новый ответ можно будет добавить, только если этот удалят.

0

Спасибо,я правильно понимаю что у меня нет возможности ответить?)

0

Может быть этот ответ удалять, т.к. он не полный - тогда и сможете

0

Ладно,буду ожидать.Спасибо за помощь,извиняюсь за то что я слишком некомпетентен в отношении сайта)))

Дан 1 ответ
0 голосов

#include
#include

float mathFunc(float x) {
if (x < 0)
return 2 * x;
else if (x > 0)
return x * x + 10;
return 0;
}

int main() {
setlocale(LC_ALL, "");

std::cout << mathFunc(-1) << " " << mathFunc(0) << " " << mathFunc(1);//проверка<br>
_getch();
return 0;
}
//1

#include
#include

int main() {
setlocale(LC_ALL, "");

int year;
while (true) {
system("cls");
std::cout << "Введите год своего рождения:";<br>std::cin >> year;//год может быть отрицательным => до н.э.

year = 2017 - year;

printf("Вам %d лет,", year);

if (year < 45)
printf("вы молоды");
else if (year < 60)
printf("вы среднего возраста");
else if (year < 75)
printf("вы пожилого возраста");
else if (year > 90)
printf("вы старческого возраста");

_getch();
return 0;
}
//2

(664 баллов)