Напишите программу, вводящую трехзначное число, первая цифра которого равна единице,...

0 голосов
34 просмотров

Напишите программу, вводящую трехзначное число, первая цифра которого равна единице, вторая принадлежит промежутку от 1 до 7, а третья на две единицы больше второй.


Информатика (328 баллов) | 34 просмотров
0

какой язык?

Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
randomize;
a:=1;
b:=random(1,7);
c:=b+2;
writeln (a,b,c);
end.

(289 баллов)
0

Ваша программа даже не скомпилируется...

0

а так? все готово!

0 голосов

Var a,b:byte;
Begin
Randomize;
a:=random(7)+1;
b:=a+2;
Write(1,a,b)
End.

(6.6k баллов)
0

Что неправильно - сказать не сможете

0

Например надо было write ('1',a,b);

0

Вы считаете, что есть какая-то разница?))

0

XD не будет выводиться 1 и без ; программа выдаст ошибку!!!

0

В Turbo, Free, ABC и ABC.NET ошибку не выдаёт. Вы, быть может, на Delphi проверяете?

0

ABC

0

Скопируйте программу и убедитесь - всё правильно работает.

0

у меня - нет

0

крч мне повиг, я только в 6 классе

0

Вижу, и с логикой, и с русским языком, и с Паскалем у Вас проблемы.. Ладно, поФиг:D