Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
85 просмотров

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For.


Информатика (12 баллов) | 85 просмотров
Дан 1 ответ
0 голосов

Program;
var a,i,sr,k,sum:integer;
k:=0;
sum:=0;
Begin
for i:=1 to 10 do
begin;
read(a);
k:=k+1;
sum:=sum+a;
sr:=sum/k;
end;
write(sr);
End.

Program;
var a,i,k,sum,sr,r:integer;
Begin
k:=0
sum:=0;
r:=0;
repeat
begin;
read(a);
k:=k+1;
sum:=sum+1;
r:=r+1;
until r=10;
sr:=sum/k;
write(sr);
End.

Цикл While  подумай сама,уверен у тебя получится

(208 баллов)
0

Спасибо