Написать программу, которая запрашивает номер дня недели и выводит его название. Включить...

0 голосов
37 просмотров

Написать программу, которая запрашивает номер дня недели и выводит его название. Включить в программу модуль CRT. Запрос и результат работы программы вывести в окнах разного цвета. Установить цвет символов по желанию.
PASCAL


Информатика (111 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;

Procedure R(Nazvanie:string; Cvet:byte);
Begin
TextBackground(Cvet);
ClrScr;
GotoXY(WindowWidth div 2-Length(Nazvanie) div 2,WindowHeight div 2);
Write(Nazvanie);
End;

Var n:byte;
Begin
HideCursor;
TextBackground(0);
ClrScr;
TextColor(15);
GotoXY(WindowWidth div 2-12,WindowHeight div 2);
Write('Введите номер дня недели');
Case ReadKey of
'1':
    R('Понедельник',4);
'2':
    R('Вторник',14);
'3':
    R('Среда',2);
'4':
    R('Четверг',9);
'5':
    R('Пятница',1);
'6':
    R('Суббота',13);
'7':
    R('Воскресенье',12);
else R('В неделе сейчас семь дней!',0);
End;
ReadKey
End.

(6.6k баллов)
0

спасибо, очень помог мне сегодня)