Дайте ответ пожалуйста!!! Ниже записана программа. Получив ** вход число , эта программа...

0 голосов
42 просмотров

Дайте ответ пожалуйста!!!
Ниже записана программа. Получив на вход число , эта программа печатает два числа, и . Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 10.
var x, a, b : integer;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 8);
x := x div 8;
end;
writeln(a); write(b);
end.


Информатика (64 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Прогоном.
a=3 => x больше  64  и не более 511 (первое число, при котором с условием x mod 8>0 цикл запускается 3 раза  и 511 последнее из таких чисел)
сам искомый иск наименьший = 106

(15.5k баллов)
0

спасибо)