КТО ХОРОШО ПОНИМАЕТ ИНФОРМАТИКУ-СЮДА!!!задание:используя синтаксис паскаль,составить...

0 голосов
22 просмотров

КТО ХОРОШО ПОНИМАЕТ ИНФОРМАТИКУ-СЮДА!!!
задание:
используя синтаксис паскаль,составить программу которая,выводит наибольший вес ягод(рассмотреть 5 разных фруктов,вес использовать среднестатистический)
мне сказали сделать все это на бумаге.помогите пожалуйста или хотя бы объясните. потому что я ничего не понимаю и не знаю с чего начать.


Информатика (77 баллов) | 22 просмотров
0

Использовать массив?

0

да

0

помогите мне кто-нибудь

Дан 1 ответ
0 голосов
Правильный ответ

Const k=5;
var a:array[1..k] of integer;
i,max:integer;
begin
for i:=1 to k do
 begin
 a[i]:=random(10)+20;
 write(a[i]:3);
 end;
writeln;
max:=a[1];
for i:=2 to k do
 if a[i]>max then max:=a[i];
writeln('max = ',max);
end.

Пример:
 26 25 21 25 20
max = 26

(194k баллов)
0

спасибо!!!

0

Пожалуйста.