Напишите программу ** языке программирования (или составьте алгоритм). Дано натуральное...

0 голосов
37 просмотров

Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n, целые числа a a an , , ..., 1 2 . Определите номер предпоследнего из членов последовательности a a an , , ..., 1 2 кратных 3; если членов, удовлетворяющих данным условиям, нет, то ответом должно быть «нет».


Информатика (22 баллов) | 37 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const n=10;
var a:array[1..n] of integer;
i,k: integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(50);
 write(a[i]:3);
 end;
writeln;
k:=0;
i:=n;
while (i>0)and(k<2) do<br> begin
 if a[i] mod 3 = 0 then k:=k+1;
 i:=i-1;
 end;
if k=2 then writeln('Искомый номер = ',i+1)
else writeln('Нет ');
end.

Пример:
22 13 42 48 26 2 18 30 11 31
Искомый номер = 7

(194k баллов)
0 голосов
Код Pascal:

Var
   n,m,i,A:integer;
Begin
Read(n);
m:=0;
i:=0;
For n:= 1 to n do
    Begin
    Read(A);
    if A mod 3 = 0 then
       if n > m then
          Begin
          i:=m;
          m:=n;
          End
    End;
if i = 0 then Write('нет')
else Write(i)
End.
(6.6k баллов)