Помогите написать программу в С++:Известен возраст группы людей в списке из 20 человек....

0 голосов
72 просмотров

Помогите написать программу в С++:Известен возраст группы людей в списке из 20 человек. Какой человек указан в списке раньше: самый старший или самый младший? (Должны учитываться первые из людей одинакового возраста.)


Информатика (12 баллов) | 72 просмотров
0

Какие входные данные? И можно пример взаимодействия программы с пользователем?

Дан 1 ответ
0 голосов

#include
#include
using namespace std;
int main()
{
int n = 20;
int p[n];
for(int i = 0; i < n; i++)
printf("%d: ", i+1),
scanf("%d", &p[i]);
int min = 100, max = 0;
int imin, imax;
for(int i = 0; i < n; i++)
{
if(p[i] < min) min = p[i], imin = i;
if(p[i] > max) max = p[i], imax = i;
}
string str = "Pervee ukazan: ";
str+=(imin printf("\n%s",str.c_str());

return 0;
}

(302 баллов)