Написать программу.Для целого числа K от 1 до 99 напечатать фразу: "Мне K лет, учитывая,...

0 голосов
78 просмотров

Написать программу.
Для целого числа K от 1 до 99 напечатать фразу: "Мне K лет, учитывая, что может быть год, лет, года.
Год: 1, 21, 31, 41... (n mod 10=1).
Лет: 5-20, 25-30, 35-40, 45-50... (n mod 10=0, 5, 6, 7, 8, 9).
Года: 2, 3, 4, 22-24, 32-34, 42-44... (n mod 10=2, 3, 4).


Информатика (12 баллов) | 78 просмотров
Дан 1 ответ
0 голосов

Var k:integer;
begin
readln(k);
case (k mod 10) of
 1 : writeln ('Мне ',k,' год'); 
 0, 5, 6, 7, 8, 9 : writeln ('Мне ',k,' лет'); 
 2, 3, 4 : writeln ('Мне ',k,' года');
end;
end.

Вот рабочее решение

(764 баллов)