Написать программу в с# двумерный массив В двумерном массиве хранится информация о...

0 голосов
52 просмотров

Написать программу в с# двумерный массив

В двумерном массиве хранится информация о количестве учеников каждом из четырех классов каждой параллели школы с первой по одиннадцатую(в первой строке – информация о первых классах, во второй – вторых и т. д.). Найти численность самого большого класса среди 10-х и 11-х классов.


Информатика (15 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;
public class Test
{
public static void Main()
{
int[,] a=new int[11,4];
Random rnd=new Random();
Console.WriteLine("");
Console.WriteLine("исходный массив");
for(int i=0;i<11;i++)<br> {
for(int j=0;j<4;j++)<br> {
a[i,j]=rnd.Next(10,30);
Console.Write(a[i,j]+" ");
}
Console.WriteLine("");
}
int max=-1;
for(int i=9;i<11;i++)<br> for(int j=0;j<4;j++)<br> if(a[i,j]>max) max=a[i,j];
Console.WriteLine("самый большой среди 10-11: "+max);
}
}

(149k баллов)