В массиве состоящим из 30 целых чисел вводят оценки 10 учениов ,Нужно вывести ** экран...

0 голосов
45 просмотров

В массиве состоящим из 30 целых чисел вводят оценки 10 учениов ,Нужно вывести на экран оценки в виде таблицы: в первом столбце номер ученика,во втором его оценки.Написать программу паскаль


Информатика (56 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a:array[1..2,1..30] of integer;
i,j:integer;
Begin
    for i:= 1 to 30 do begin
        writeln('Введите номер ученика:');
        read(a[1,i]);
        writeln('Введите оценку:');
        read(a[2,i]);
    end;
    
    for i:= 1 to 10 do begin
      writeln(i:2,' - ');
        for j:= 1 to 30
          if a[1,j]=i then
                write(a[2,i],' ');
    end;        
    readkey;
End.   

(53.1k баллов)