Напишите программу которая определяет находится ли введеный год в прошлом настоящем или...

0 голосов
50 просмотров

Напишите программу которая определяет находится ли введеный год в прошлом настоящем или будущем (работа в паскале
)


Информатика (22 баллов) | 50 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const    current_year = 2017;


var    year: integer;


begin

    readLn(year);

    if year < 2017 then 

        Write(year, ' прошлое')

    else if year = 2017 then 

        Write(year, ' настоящее')

    else if year > 2017 then 

        Write(year, ' будущее')

end.

(55.0k баллов)
0 голосов

Проблем быть не должно, думаю, это самое примитивное.
Program asd;
Var x: integer;
Begin
read(x);
if x<2017 then Write(' — ',x,' год уже прошел.') else <br>if x=2017 then Write(' — ',' Сейчас — ',x,'.') else
if x>2017 then Write(' — ',x,' Еще не настал.')
end.

Надеюсь, помог.
Буду благодарен, если выберешь "Лучший"
Удачи!


0

Скажите почему ошибку выдает.. После бегин там с о знаками проблемки да

0

Исправил, проверь, пожалуйста, снова

0

Спасибо огромное

0

не за что. Если что, обращайся. )

0

только без написания сайтов ))