Напишите программу пожалуйста!!! ПЕРВОМУ ЛУЧШИЙ ОТВЕТ!!!

0 голосов
26 просмотров

Напишите программу пожалуйста!!! ПЕРВОМУ ЛУЧШИЙ ОТВЕТ!!!


image

Информатика (666 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

Var
   A,N,i,j,o:integer;
Begin
Write('Начальное значение: ');ReadLn(A);
Write('Размер таблицы: ');ReadLn(N);
o:=Sqr(N+A);
if Frac(Ln(o)/Ln(10)) <> 0 then o:=2+Trunc(Ln(o)/Ln(10))
else o:=1+Trunc(Ln(o)/Ln(10));
N:=N-1;
Write('':(o+1));
For i:= A to A+N do
    Write(i:o,' ');
WriteLn;
For i:= A to N+A do
    Begin
    Write(i:o);
    For j:= A to A+N do
        Write(' ',i*j:o);
    WriteLn
    End;
End.

(6.6k баллов)