Помогите пожалуйста! Нужно составить блок схему и написать программу в ТурбоПаскаль

0 голосов
40 просмотров

Помогите пожалуйста! Нужно составить блок схему и написать программу в ТурбоПаскаль


image

Информатика (12 баллов) | 40 просмотров
0

Попадает ли заданная точка в закрашенную область?

0

Да, верно, не дописала до конца

Дан 1 ответ
0 голосов

Var X,Y,R:real;
Begin
Write('x = ');ReadLn(x);
Write('y = ');ReadLn(y);
R:=X*X+Y*Y;
if R > 1 then
   if x > 0 then
      if y > 0 then Write(R < 4)
      else Write(R < 25)
   else if y < 0 then Write(R < 16)
        else Write(R < 9)
else Write(false)
End.


image
(6.6k баллов)