Составьте программу , которая формирует массив из 40 случайных целых чисел от 0 до 20 и...

0 голосов
51 просмотров

Составьте программу , которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
а) среднее арифметическое нечётных чисел
б) сумму чисел, не превышающих 10
в) сумму чисел кратных 3
На экран выводятся исходные значения и результаты вычислений.


Информатика (25 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Program Task;
Var a: Array [1..40] of Integer;
b: Real;
c, d, e, i: Integer;
Begin
Randomize;
For i := 1 To 40 Do
a[i] := Random(20 + 1);
WriteLn('Массив:');
For i := 1 To 40 Do
Write(a[i], ' ');
WriteLn;
For i := 1 To 40 Do
Begin
If a[i] Mod 2 = 1 Then
Begin
b := b + a[i];
c := c + 1;
End;
If a[i] <= 10 Then<br>d := d + a[i];
If a[i] Mod 3 = 0 Then
e := e + a[i];
End;
WriteLn('Среднее арифметическое нечётных чисел: ', (b / c):2:2);
WriteLn('Сумма чисел, не превышающих 10: ', d);
WriteLn('Сумма чисел кратных 3: ', e);
ReadLn;
End.

(2.8k баллов)