Написать программу для нахождения суммы 1/1+1/2+1/3+....1/n

0 голосов
33 просмотров

Написать программу для нахождения суммы 1/1+1/2+1/3+....1/n


Информатика (37 баллов) | 33 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var i, n: integer;
S: real;
Begin
Readln(n);
S:=0;
For i:=1 to n do S:=S+1/i;
Write ( '  Сумма равна: ', S );
Readln;
End.    

(828 баллов)
0

thank you

0 голосов

Pascal:

Turbo/Free/ABC:

Var
   n:integer;
   S:real;
Begin
S:=0;
Write('n = ');
ReadLn(n);
For n:= 1 to n do
    S:=S+1/n;
WriteLn('S = ',S);
End.



PascalABC.NET 3.2 (сборка 1467 от 02.06.2017):

Begin
Write('S = ',ReadInteger('n = ').Range.Sum(x->1/x))
End.

(6.6k баллов)