Помогите! Нужно написать программу. Дана линейная функция y=kx+b . k и b вводятся с...

0 голосов
38 просмотров

Помогите!

Нужно написать программу. Дана линейная функция y=kx+b .
k и b вводятся с клавиатуры. Рассмотреть все способы,где числа могут быть отрицательными и положительными, посчитать. Составной условный оператор.


Информатика | 38 просмотров
0

и мне скинь)

0

пожалуйста

0

Скинул.

0

Доктор математических наук, профессор Mefody66 сейчас опубликует свою научную статью!))

0

Pauel, спасибо за комплимент, но я не профессор математики. И я тоже не понял, в чем суть задания. Написал, как сумел.

Дан 1 ответ
0 голосов
Правильный ответ

На Visual Basic. Делаешь 4 текстовых поля под a, b, x, y
Dim a As Double, b As Double, x As Double, y As Double
a = Text1.Text: b= Text2.Text: x = Text3. Text
y = a*x + b
Text4.Text = y
End Sub
Вот и все. 
Независимо от положительных и отрицательных а и b, получаешь ответ.
Если же надо просчитать при разных х от х1 до х2, то 5 полей
Dim a As Double, b As Double , i As Integer
Dim  x1 As Integer,  x2 As Integer, y As Double
Text5.MultiLine = True
a = Text1.Text: b= Text2.Text: x1 = Text3. Text, x2 = Text4.Text
Text5.Text = ""
For i = x1 To x2
y = a*i + b
Text5.Text = Text5.Text & Str(y) & vbCrLf
Next i
End Sub

(320k баллов)
0

Тогда может быть так:

0

Dim a As Double, b As Double, x As Double, y As Double
a = Text1.Text: b= Text2.Text: x = Text3. Text
y = a*x + b
If y > 0 Then Text4.Text = "y > 0" Else Text4.Text = "y < 0"
End Sub

0

в целых числах решит или в любых?

0

В любых, они же все типа Double, что значит - дробные двойной точности.

0

program gt;

0

kage1998, я не понял, что такое program gt;

0

var b,k,x,y:real; begin read(k,b); x:=-round(b/k)-1;y:=k*x+b;writeln(x,' ',y);x:=-round(b/k)+2;y:=k*x+b;write(x,' ',y);end.

0

program gt;-название программы на паскале

0

у меня в решении 2 ответа первый для отрицательных а второй для положительных(если нужно несколько значений нужно добавить for и все)

0

Понятно, спасибо за разъяснение!